Solved. Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Business edition tips, tricks, problems and discussions

Moderators: Max, TerryRogers

Post Reply
Trinitylab
Guru
Posts: 661
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 16 times
Been thanked: 40 times

Solved. Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by Trinitylab »

Win8.1 x64, the newest EPIM Biz pro whatever.
Some tasks have 'read only' attribute.
In order to turn it off, I need to open the task.
No possibility to do it using RMB > Read only.
Very inconvenient if you have 30 tasks in the default list, which is copied, and you have to open each task to make it editable.

Expected beh:
as it was before.
Mark ctrl+A all the task, RMB > Read only > turn off.
Last edited by Trinitylab on Wed Dec 16, 2020 4:09 pm, edited 1 time in total.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 16 GB RAM or Win 10 Pro, i7, 16 GB RAM.
Trinitylab
Guru
Posts: 661
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 16 times
Been thanked: 40 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by Trinitylab »

Hello guys, anybody any clues?
I have now a couple of hundreds of single tasks, which, copied from a "task scheme", need to be manually opened and set to editable.
What was the reasoning behind removing possibility to use Ctrl+A and RMB?
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 16 GB RAM or Win 10 Pro, i7, 16 GB RAM.
admin
Site Admin
Posts: 12577
Joined: Thu Nov 25, 2004 3:12 am
Has thanked: 1125 times
Been thanked: 780 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by admin »

It works as expected on our end. Please check if the same issue happens with a new database.
Android version of EssentialPIM. Keep all your data in sync!
Trinitylab
Guru
Posts: 661
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 16 times
Been thanked: 40 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by Trinitylab »

With the new it is OK.
So compatibility needed.
I think you could make tests on the old dbases, along with the new ones. Otherwise you get different behaviours.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 16 GB RAM or Win 10 Pro, i7, 16 GB RAM.
admin
Site Admin
Posts: 12577
Joined: Thu Nov 25, 2004 3:12 am
Has thanked: 1125 times
Been thanked: 780 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by admin »

I think the issue is not with compatibility. We could have a look if your copy your database file, then open the newly created copy, delete anything except for couple of read-only tasks from it, then save,optimize and forward the resulting database to me via PM.

You can also get the correct behavior now by syncing your database to the new fresh one using EPIM Sync.
Android version of EssentialPIM. Keep all your data in sync!
Trinitylab
Guru
Posts: 661
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 16 times
Been thanked: 40 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by Trinitylab »

@admin, thanks, please first check against Network and local PC. No need to send you db, see below:

if I open the same db from local PC, just like a file, everything works fine.
If I open this db over server (Connect to server and so on), then the problem appears.

The same exactly happens with the new DB, empty, just one test task.

Please fix the bug introduced during the latest update.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 16 GB RAM or Win 10 Pro, i7, 16 GB RAM.
admin
Site Admin
Posts: 12577
Joined: Thu Nov 25, 2004 3:12 am
Has thanked: 1125 times
Been thanked: 780 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by admin »

Got it, will attempt to fix in the upcoming 9.2 version.
Android version of EssentialPIM. Keep all your data in sync!
Trinitylab
Guru
Posts: 661
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 16 times
Been thanked: 40 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by Trinitylab »

Seems to got fixed, thank you. One thing to possibly improve: the icon which indicates 'read only', in the db open locally, is a red circle with white short line inside.
When it is opened via server, this is black and white.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 16 GB RAM or Win 10 Pro, i7, 16 GB RAM.
admin
Site Admin
Posts: 12577
Joined: Thu Nov 25, 2004 3:12 am
Has thanked: 1125 times
Been thanked: 780 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by admin »

Thanks for the confirmation!
The difference in icons is because of a bit different meaning for the option in the Business edition. In the Business edition it means that noone including other users would be unable to edit the item.
Android version of EssentialPIM. Keep all your data in sync!
Trinitylab
Guru
Posts: 661
Joined: Mon Jan 23, 2012 1:31 pm
Has thanked: 16 times
Been thanked: 40 times

Re: Bug: 'read only' in Tasks cannot be set off using RMB > turn off 'Read only'

Post by Trinitylab »

Thank you, if it is on purpose then OK, I have no further questions your Honour.
EPIM Pro Business Network always newest
Win 8.1 Pro 64x, C2D 2x3GHz, 16 GB RAM or Win 10 Pro, i7, 16 GB RAM.
Post Reply